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Construction Planning, Equipment and Methods 
ENGI 8749 

Fall Semester, 2008 
Tutorial #2 – Resource Leveling using MS Project 

 

 

Project Example Overview 

 

Microsoft Project, in addition to scheduling calculations, can also track resources and 

consider cases of resource limitations in scheduling project activities.  During our last 

lecture (Lecture 14) on resource allocation, we considered an example project that had a 

resource limitation.  Without resource limitations we found that with a forward and 

backward pass on the project, it would take 12 days to complete.   

 

 
 

We can see that a resource limit of 2/day has been imposed in this problem and we found 

that through a hand calculation that this limitation added an additional 2 days to the 

project timeline (14 days total).  This occurs because after activity A is completed we see 

that 3 resources per day are required. 

 

Before we get into resource allocation we set up MS Project from a blank project by 

adding the following data: 

 

Task Name (Index) Duration Predecessors (Index) 

A (1) 1 - 

B (2) 2 A (1) 

C (3) 2 A (1) 

D (4) 3 A (1) 

E (5) 4 B (2) 

F (6) 5 C (3) 

G (7) 4 D (4) 

H (8) 1 E,C (5,3) 

I (9) 3 G (7) 

J (10) 1 H,F,I (8,6,9) 
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Starting Project 

 

So that we can easily count project days, we’ll start our project from the 1
st
 of a 30 day 

month so that the dates reflect the days.  We’ll also make Saturdays and Sundays work 

days for this purpose.  Additionally, we’ll change the date bars to weeks and days from 

the start of the project.  These steps were outlined in the previous tutorial. 

 

1. Set project start date to April 1
st
 

2. Define Saturdays and Sundays as work days (change standard calendar) 

3. Change calendar bars to time from start of project 

4. Add info in table. 

 

After we complete these steps our schedule should appear as: 

 

 
 

Here, we can see that the project is to be completed in 12 days.  However, we can also 

see from the Gantt chart view that there are a number of days (2-8) when 3 activities will 

be occurring at the same time.  Hence, we will require 3 resources on these days. 

 

Next, we’ll customize the network view but this can be skipped over if necessary.  I had 

challenged myself to try this customization and wanted to document it. 
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Project Customization 

 

 

We can also view our network view (View > Network Diagram) to confirm the network 

is the same as the example.  Like many aspects of MS Project, it is very customizable.  In 

fact, we can customize the network view to reflect the information we have in our 

problem.  To do this we’ll create a new template for the network view by following: 

 

1. Change to network view (View > Network Diagram) 

2. Select Format > Box Styles … and the following dialogue box will appear 

 

3. You’ll note the Standard data template is in use.  Select the  

button to reveal another dialogue: 
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4. Drilling deeper, we now create a new template by selecting the .  We’ll call 

this template “Event Times” and put EST, EFT, LST, LFT in the corners of a 2x3 

matrix we set out from the  button.  From the “Choose Cell” area we can 

pull down the field variables we can add to the boxes to assemble the box we need 

 

5. Finally we apply this new template to the “Critical” and “Noncritical” box styles 

from the first dialogue box we encountered in step 2. 

This produces a network view that compares to our original problem view as: 
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Defining Project Resources 

 

A resource is traditionally defined as any of the people, equipment, and materials used to 

complete tasks that make a project.  Material resources are differentiated from people and 

equipment resources, as they are not time dependent.  Before we use resources in our 

activities we must create a resource list.  One can follow the  wizard from the 

Tasks menu but most of these steps are not necessary for our simple projects.  To create a 

local resource list for our project change the view to View > Resource Sheet and add a 

new resource called R1.  You’ll get an entry as follows: 

 

 
 

Here, we need to make sure that the “Type” column is set to Work.  This specifies that the 

people or equipment resource will be utilized while it is assigned and will be prorated 

across the activity time.  We could specify an hourly rate for our resources if we were 

tracking cost or a lump sum cost each use of the resource. 

 

You’ll also note the resource can also use its own calendar that might be independent of 

the standard calendar.  Finally, we can specify the maximum number of units for our 

resource.  In this case we have been told in the problem that we have a maximum of 2-

resource units per day so we change “Max. Units” to 200%. 

 

 
 

There are lots of other ways to add resources to projects and modify them but this seems 

to be the base method.  We can add any number of resources to this list if we are tracking 

a multi-resource project.  These represent pools of resources we can draw from and 

therefore, have not been allocated for use at this point. 
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Allocating Resources 

 

Once we have a pool of resources to draw from, we can assign these to various activities.  

This is done for each activity and can be done in the default Gantt chart view by selecting 

the resource required from the pull down menu in the “Resource Name” column. 

 

 
 

We can also double click on any activity and select the “Resource” tab from the main 

Task Information dialogue as follows: 

 

 
 

If we required more than 100% of a resource for a particular item, we would specify this 

in the units column of the Task Information or type the information in brackets in the 

Gantt chart view as R1[200%].  Commas separate multiple resource assignments. 

 

For our project each activity uses 1 resource while it is scheduled so each row of the 

“Resource Name” column will have an R1 entry. 
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Tracking Resources 

 

Now that we have assigned resources we can track them to see how they are being 

allocated on our project.  The best way to view resource utilization is through a split 

window view.  Select Window > Split and maintain the Gantt View in the top window.  

Select the bottom panel and change this view to resource utilization by selecting View > 

Resource Graph.  You should have a view as follows: 

 
 

Here we see that for the resource R1 that we are using 1-unit on days 1, 9-12 while using 

3 units for days 2-8.  This corresponds to our earlier suspicion of resource over allocation 

and this over allocation is show by the  bars that show the maximum resource 

availability of 2 units.  The red bars indicate days in which the resource is over allocated. 

 

Note: if two resources were tracked in the Resource Graph then the scroll bar on the 

bottom left-side of the plot would be used to scroll through the various resources. 

 

Resource Allocation  

 

We note here that if we are limited with our resources to 2 units per day then we cannot 

do the project as we had initially planned.  We are forced to delay activities until 

resources are free to undertake the activity.  If we delay critical activities then the end 

date of the project will be extended.  MS Project has a tool for allocating resources to 

minimize the impact on the project schedule. 

 

Before using the resource leveling tool change to top panel to Leveling Gantt view by 

selecting the top view and selecting View > More Views… Select Leveling Gantt. 
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You’ll notice here that a new column is added in this view called “Leveling Delay”.  

There is not much hand leveling we could do with the exception of activity H.  If we 

added a 1 day (elapsed day, eday) to activity H, we would reschedule activity H to day 9 

from 8.  The result would be a gradual resource reduction as follows: 
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If we disregard the 12 day end date of the project, we can reassign the tasks based on 

resources available.  We had undertaken this by hand calculation in class (Lecture 14) 

using the ELS heuristic rule for deciding upon activities to schedule.   

 

The leveling tool in MS Project is initiated by selecting Tools > Level Resources… from 

the top menus.  This brings up the following dialogue box: 

 

 
 

Leveling can be set to occur manually or automatically (I select manual to see the impact 

of changes I’ve made).  The project can be leveled over the whole or only parts of the 

project.  The main part of the dialogue is the Resolving overallocations section.  In 

leveling order the heuristic rules for delaying activities are decided.  For ID only, 

activities are assigned based on their ID (1 -> 10 in our example).  In standard, the 

assignment is based on least total float (LTF) and later priority.  In Priority, Standard 

mode, you can assign a priority from 1 -> 1000 in the Task Information dialogue box and 

this will be first used to select activities.  Other options for level ordering constrain the 

solution to the project end date (1
st
 option), allows leveling to adjust when a resource 

works on a task independent of the other resources working on the same task (2
end

 

option), and allows tasks to split (3
ed

 option).  Options 2 and 3 are checked by default. 

 

The workflow here is to first clear leveling , change any of the required settings 

and then reschedule the work with the  button.  The first result from our example 

yields a similar result to our hand calculation.  However, the result is 15 days rather than 

14 days as follows: 
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Here you should note the following: 

 

• The green bars show the result of the previous leveling excise 

• The blue bars show the current leveling result activities 

• The brown lines to the left of the activity are the leveling delay imposed (C,E,F) 

• The blue line to the right of the activities are the free float available (H,I) 

• The … indicates a split activity (I) 

 

The result of leveling shows that project was extended the project by three days.  

However, resources on days 13 and 14 could be combined to reduce the schedule by one 

day.  However, this would involve moving activity F back a day and rescheduling other 

tasks.  This can be done by increasing the priority of F in the Task Information dialogue 

to 520.  This is slightly higher then the 500 default level set for other activities. 
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If we now re-level the activities, we note that the Leveling Delay for activity F has been 

reduced from 4 to 3 days and the remaining activities scheduled accordingly. 

 

 
 

With this change the duration of the project is reduced now to 14 days.  This is the same 

result as was obtained in our hand calculation.  We see from the resource graph that the 

work has been scheduled with maximum of 2 resource units.  Given that activities A and 

J must occur alone, this is optimal result for the resource restriction. 
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Reducing Length of Project 

 

If we examine the new critical path, we note substantial changes due to resource leveling.  

This is most often the case.  Of course to reduce the duration B,C,E,F or H would require 

the addition of a new resource.  Otherwise the only opportunity to reduce the project 

duration would be to reduce the durations of the beginning & end activities (A&J) by 

possibly utilizing 2 resource units on those days to reduce them to 0.5 days each.  This 

would reduce the overall project to 13 days (only 1 greater than the original) and have a 

constant resource utilization of 2 units. 

 

 
Critical Path with Resource Leveling 

 
Critical Path without Leveling 

 

 

Note: Take care when changing the duration of or resources allocated to an activity.  

Activities become effort driven when resources are utilized.  The default setting used is 

constant units.  This means that a unit of resource effort has a constant capacity.  If you 

decrease activity duration more resources are assign or the total effort (work) in the 

activity is reduced.  If you assign more resources, this reduced activity duration or 

increases work effort. 


